Announcements about Solo Build it!, SBI! for WP, WordPress, and other related news and announcements are posted here. You can either follow the news here, in Site Central, via the SBIX newsletter or in your WordPress dashboard (if using SBI! for WordPress).

Moderator: Debs from barkinista.com

#1364815 by A J from Somewhere Hot
Sat Feb 11, 2017 7:15 am
Maybe I did it wrong, as I used the same keys for both sites, however, both sites have the contact working correctly as I have tested the forms.

You'll use one Google account for all your domains. However, it's not the same code. When you go to the reCaptcha Admin site at Google, they'll have steps for you to add new domains and get new key pairs.


What I did was set up my google info for one domain first, the travel site. Added that to my connected services in Site Central and it all worked perfectly. Then I decided to add my roses site to the google info, where you put each domain on a new line. Did that and saved, it didnt give me any different key numbers that I could see, so I just used the ones I used for the travel site.

Testing that contact form, it all worked correctly, and I got my test emails come through, so seems like one set of key numbers works for both sites. Or at least it did for me. :D

Cheers, AJ
#1364935 by Vinny Alves, SiteSell WordPress Dev
Mon Feb 13, 2017 4:12 pm
Maybe I did it wrong, as I used the same keys for both sites, however, both sites have the contact working correctly as I have tested the forms.


Hi AJ,

You're probably using what they call Global Keys. If it's working, great. Safest bet is to click the domain in the domain list and then "Keys" link under "Adding reCAPTCHA to your site".

Cheers,
Vinny
#1364940 by Martin from Tolkamer
Mon Feb 13, 2017 4:55 pm
This is a bump from David from 03-02 for those of you who experience this:
"Yay - it works!

One thing for people to note, is that in BlockBuilder, when you Preview your contact page with the reCaptcha activated, the reCaptcha box will give an error message - Don't worry about this...

The error message relates to the reCaptcha 'Site Key' being incorrect. This is because when you set up the reCaptcha, you added / registered your website's address. You'll see that the BlockBuilder's Preview window has a different website address to the one you registered with reCaptcha, hence the verification error when previewing your page.

When you refresh your own website after building it, the reCaptcha works perfectly :D

All the best,
David

And of course Thnx David.
Similar Topics Statistics Last post
Release: February 8, 2017 - reCaptcha Option for C2 Invitations
by ken-admin Thu Feb 09, 2017 5:08 pm
2 Replies
569 Views
by Claude from hamradiosecrets.com
Fri Feb 10, 2017 9:15 pm
Release May 25, 2016: Updated (and Easier to Use) Fav It!
1, 2 by Help Elf from SiteSell Wed May 25, 2016 5:28 pm
15 Replies
1127 Views
by Mary from Mico
Fri Jun 10, 2016 7:11 am
August 23 Release: Content 2.0 Subordinate Login
by Help Elf from SiteSell Tue Aug 23, 2016 6:59 pm
5 Replies
563 Views
by Ola from Qidron
Mon Aug 29, 2016 1:13 pm
Release June 14, 2016: A Sparkling New Site Designer Gallery
1 ... 4, 5, 6 by Help Elf from SiteSell Tue Jun 14, 2016 8:22 pm
77 Replies
2508 Views
by Jill from Mullengudgery
Thu Aug 04, 2016 8:21 am
Release May 31, 2016: Cloning Blocks, Same Page and Multiple Pages Across Your Site
1, 2, 3 by Help Elf from SiteSell Tue May 31, 2016 5:00 pm
35 Replies
2191 Views
by Tracey from Du Toitskloof
Thu Aug 11, 2016 10:55 pm

Users browsing this forum: No registered users and 1 guest