Announcements about Solo Build it!, SBI! for WP, WordPress, and other related news and announcements are posted here. You can either follow the news here, in Site Central, via the SBIX newsletter or in your WordPress dashboard (if using SBI! for WordPress).

Moderator: Debs from SiteSell

#1364815 by A J from Somewhere Hot
Sat Feb 11, 2017 7:15 am
Maybe I did it wrong, as I used the same keys for both sites, however, both sites have the contact working correctly as I have tested the forms.

You'll use one Google account for all your domains. However, it's not the same code. When you go to the reCaptcha Admin site at Google, they'll have steps for you to add new domains and get new key pairs.


What I did was set up my google info for one domain first, the travel site. Added that to my connected services in Site Central and it all worked perfectly. Then I decided to add my roses site to the google info, where you put each domain on a new line. Did that and saved, it didnt give me any different key numbers that I could see, so I just used the ones I used for the travel site.

Testing that contact form, it all worked correctly, and I got my test emails come through, so seems like one set of key numbers works for both sites. Or at least it did for me. :D

Cheers, AJ
#1364935 by Vinny Alves, SiteSell WordPress Dev
Mon Feb 13, 2017 4:12 pm
Maybe I did it wrong, as I used the same keys for both sites, however, both sites have the contact working correctly as I have tested the forms.


Hi AJ,

You're probably using what they call Global Keys. If it's working, great. Safest bet is to click the domain in the domain list and then "Keys" link under "Adding reCAPTCHA to your site".

Cheers,
Vinny
#1364940 by Martin from Tolkamer
Mon Feb 13, 2017 4:55 pm
This is a bump from David from 03-02 for those of you who experience this:
"Yay - it works!

One thing for people to note, is that in BlockBuilder, when you Preview your contact page with the reCaptcha activated, the reCaptcha box will give an error message - Don't worry about this...

The error message relates to the reCaptcha 'Site Key' being incorrect. This is because when you set up the reCaptcha, you added / registered your website's address. You'll see that the BlockBuilder's Preview window has a different website address to the one you registered with reCaptcha, hence the verification error when previewing your page.

When you refresh your own website after building it, the reCaptcha works perfectly :D

All the best,
David

And of course Thnx David.
Similar Topics Statistics Last post
Release: February 8, 2017 - reCaptcha Option for C2 Invitations
by ken-admin Thu Feb 09, 2017 5:08 pm
2 Replies
836 Views
by Claude from hamradiosecrets.com
Fri Feb 10, 2017 9:15 pm
Release: June 8, 2017: Action Guide Tasks (Interactive, Too!)
by ken-admin Thu Jun 08, 2017 5:37 pm
4 Replies
587 Views
by Moorea S. from USA
Wed Jun 14, 2017 3:49 pm
Release: March 28, 2017: Anti-Spam and Quick Preview It! Enhancements
by Help Elf from SiteSell Tue Mar 28, 2017 7:51 pm
11 Replies
1510 Views
by Claude from hamradiosecrets.com
Tue Apr 04, 2017 2:33 pm
Release: April 19: C2 and Special File Manager
by ken-admin Wed Apr 19, 2017 5:29 pm
6 Replies
879 Views
by ken-admin
Thu Apr 20, 2017 5:25 pm
October 11 Release: Brainstormer Keyword Limits Increased
by Help Elf from SiteSell Tue Oct 11, 2016 8:45 pm
5 Replies
964 Views
by Mary from Mico
Thu Oct 27, 2016 6:58 pm

Users browsing this forum: Cath, SiteSell Content Team, Julie from Adona and 1 guest